Repository navigation
Conversation
tornado 6.5.10 carries CVE-2026-115927, CVE-2026-116577 and CVE-2026-116578, fixed only in 6.6, which requires Python 3.11. The security floor is split by Python version, as for pillow and dnspython: 6.6 on 3.11+, the old 6.5.9 floor on 3.10, which stays exposed. Only the tornado blocks and content-hash were spliced into the lock. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_01HwkxN8YriHhdXBwMc4sd8h
Contributor
|
📦 Python package built successfully!
|
Codecov Report✅ All modified and coverable lines are covered by tests. Additional details and impacted files@@ Coverage Diff @@
## main #146 +/- ##
=======================================
Coverage 78.17% 78.17%
=======================================
Files 120 120
Lines 6837 6837
Branches 990 990
=======================================
Hits 5345 5345
Misses 1182 1182
Partials 310 310
Flags with carried forward coverage won't be shown. Click here to find out more. ☔ View full report in Codecov by Harness. |
|
🚀 Review App Deployment Started
|
This branch has not been deployed
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
Audit - ProductionandAudit - Serverfail on the latest PR run, 40929536773 ontk/servable-stored-dataframes(2026-10-29). The cause is three tornado advisories published on 2026-10-28. All three are fixed only in tornado 6.6, which requires Python 3.11, so the tornado security floor is split by Python version, as pillow and dnspython already are. Noignore-vulnsentries are added.Why the change looks the way it does
RedirectHandleropen redirect.< 6.6as vulnerable and 6.6 as the first patched release. There is no 6.5.x backport; 6.5.10 is the last 6.5 release.>=6.1/>=6.2.<7, but it only installs on 3.10, which stays on 6.5.10.web.authenticatedandweb.HTTPErroron a jupyter-serverAPIHandlerindeepnote_core/widget_assets.py. None of the 6.6 changes touch it:data_receivedchunk mergingRedirectHandler/StaticFileHandlerhardeningcheck_originchangescross_origin_protection, which is opt-in in 6.6HTTPServerRequest(start_line=...)deprecation, fixed in test code only (jupyter_server#1717).<7, like every other line in the block. The 6.6 notes saycross_origin_protectionis expected to become the default in 6.7. That is worth checking when 6.7 ships, given the Jupyter server runs withdisable_check_xsrf = True.Lock file
tornadoblocks andcontent-hash.markers = "python_version == \"3.10\"".>= 3.11.poetry lockonmainstill rewrites about 25 unrelated per-Python entries.pyproject.toml, the spliced lock's tornado blocks and content-hash match exactly. Every other difference is that pre-existing drift.Testing
poetry check --lockpasses.--require-hashes --disable-pip, ignoring only PYSEC-2024-161 and PYSEC-2026-113), on the Production, Server and Dev exports:uv pip compile pyproject.toml --extra server, as in Wheel Install Check, resolves on 3.10–3.14: tornado 6.5.10 on 3.10 and 6.6 on 3.11+.-W error::DeprecationWarning:tornado.tests/unit/test_widget_assets.py: 38 passed.Not in this PR
🤖 Generated with Claude Code
https://claude.ai/code/session_01HwkxN8YriHhdXBwMc4sd8h
Summary by CodeRabbit