Skip to content

Last update of nginx config breaks rainloop and ldap_user apps #195

Description

@sepo83

linuxserver.io


Expected Behavior

Rainloop app shows up. ldap_user app shows current configuration in settings.

Current Behavior

Rainloop app only shows a blank screen. ldap_user app shows an empty configuration in settings.

Reason seems to be the updated nginx/site-confs/default. I know that it was done according to official nextcloud documentation.
Issues are already discussed e.g.:

Steps to Reproduce

  1. apply 8681226 to nginx/site-confs/default resp. update the docker-image, delete nginx/site-confs/default and restart the container
  2. reverting nginx/site-confs/default to previouse version makes rainloop and ldap_user apps work again

Environment

OS: Linux 5.6.0-0.bpo.2-amd64 #1 SMP Debian 5.6.14-2~bpo10+1 (2020-06-09) x86_64 GNU/Linux
CPU architecture: x86_64
How docker service was installed:

as provided by OpenMediaVault

Command used to create docker container (run/create/compose/screenshot)

Docker logs

e.g. log/nginx/error.log

2021/03/28 17:12:24 [error] 413#413: *117 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Class 'OC' not found in /config/www/nextcloud/apps/rainloop/app/index.php:8
Stack trace:
#0 /config/www/nextcloud/apps/rainloop/app/rainloop/v/1.15.0/include.php(57): __get_custom_data_full_path()
#1 /config/www/nextcloud/apps/rainloop/app/index.php(23): include('/config/www/nex...')
#2 {main}
  thrown in /config/www/nextcloud/apps/rainloop/app/index.php on line 8" while reading response header from upstream, client: 192.168.xxx.xxx, server: _, request: "GET /apps/rainloop/app/?OwnCloudAuth HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "xxxx"

Activity

  1. github-actions commented on Mar 28, 2021

    @github-actions

    Thanks for opening your first issue here! Be sure to follow the bug or feature issue templates!

  2. sepo83 commented on Mar 28, 2021

    @sepo83
    Author

    I found this workaround nextcloud/documentation#2197 (comment) which works for me.

  3. github-actions commented on Apr 28, 2021

    @github-actions

    This issue has been automatically marked as stale because it has not had recent activity. It will be closed if no further activity occurs. Thank you for your contributions.

  4. llasse commented on May 23, 2021

    @llasse

    Not sure if this is related, however I do have a problem when trying to use the ldap / ad integration app in nextcloud (21.02) which does not let me proceed further when entering my ldap-credentials (doesnt show any error either, just locks me without any further messages)
    as far as I understand it this is an nginx-config related problem:
    nextcloud/server#24314
    nextcloud/server#16194

  5. docfactory37 commented on May 24, 2021

    @docfactory37

    im also having this isssue

  6. github-actions commented on Aug 4, 2021

    @github-actions

    This issue has been automatically marked as stale because it has not had recent activity. It will be closed if no further activity occurs. Thank you for your contributions.

  7. locked as resolved and limited conversation to collaborators on Apr 3, 2023
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions